]> Pileus Git - ~andy/sunrise/blob - sci-biology/repeatmasker/repeatmasker-3.1.8.ebuild
sci-biology/tgi-tools: Add local useflags to metadata.xml (GLEP 56)
[~andy/sunrise] / sci-biology / repeatmasker / repeatmasker-3.1.8.ebuild
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit versionator
6
7 MY_PV=$(replace_all_version_separators '-')
8
9 DESCRIPTION="Screen DNA sequences for interspersed repeats and low complexity DNA"
10 HOMEPAGE="http://repeatmasker.org/"
11 SRC_URI="http://www.repeatmasker.org/RepeatMasker-open-${MY_PV}.tar.gz"
12
13 LICENSE="OSL-2.1"
14 SLOT="0"
15 KEYWORDS="~x86"
16 IUSE=""
17
18 DEPEND=""
19 RDEPEND="sci-biology/phrap
20         sci-biology/repeatmasker-libraries"
21
22 S="${WORKDIR}/RepeatMasker"
23
24 src_compile() {
25         sed -i 's/system( "clear" );//' "${S}/configure"
26         cat << END | "${S}/configure" || die "configure failed"
27
28 /usr/bin
29 /usr/share/${PN}
30 1
31 /usr/bin
32 Y
33 4
34 END
35         sed -i '/$REPEATMASKER_DIR/ s|$FindBin::RealBin|/usr/share/'${PN}'|' "${S}/RepeatMaskerConfig.pm" || die "sed failed"
36         sed -i 's|use lib $FindBin::RealBin;|use lib "/usr/share/'${PN}'/lib";|' "${S}"/{DateRepeats,ProcessRepeats,RepeatMasker} || die "sed failed"
37 }
38
39 src_install() {
40         dobin DateRepeats ProcessRepeats RepeatMasker
41
42         insinto /usr/share/${PN}/lib
43         doins "${S}"/*.pm
44
45         insinto /usr/share/${PN}
46         doins -r util Matrices
47         keepdir /usr/share/${PN}/Libraries
48
49         dodoc README repeatmasker.help daterepeats.help
50 }