]> Pileus Git - ~andy/sunrise/blob - sci-biology/phrap/phrap-0.990329.ebuild
Cosmetics
[~andy/sunrise] / sci-biology / phrap / phrap-0.990329.ebuild
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 DESCRIPTION="Phrap, swat, cross_match: Shotgun assembly and alignment utilities"
6 HOMEPAGE="http://www.phrap.org/"
7 SRC_URI="phrap-distrib.tar.Z"
8
9 LICENSE="phrap"
10 SLOT="0"
11 KEYWORDS="~x86"
12 IUSE=""
13
14 DEPEND=""
15 RDEPEND=""
16
17 S="${WORKDIR}"
18
19 RESTRICT="fetch"
20
21 pkg_nofetch() {
22         einfo "Please visit http://www.phrap.org/phredphrapconsed.html and obtain the file"
23         einfo '"distrib.tar.Z", then rename it to "phrap-distrib.tar.Z" and put it in'
24         einfo "${DISTDIR}"
25 }
26
27 src_compile() {
28         sed -i 's/CFLAGS=/#CFLAGS=/' makefile
29         sed -i 's|#!/usr/local/bin/perl|#!/usr/bin/perl|' phrapview
30         emake || die "emake failed"
31 }
32
33 src_install() {
34         dobin cluster cross_match loco phrap phrapview swat
35         for i in {general,phrap,swat}.doc ; do 
36                 newdoc ${i} ${i}.txt
37         done
38 }