]> Pileus Git - ~andy/sunrise/blob - sci-biology/clover/clover-2006.07.17.ebuild
sci-biology/sibsim4: version bump
[~andy/sunrise] / sci-biology / clover / clover-2006.07.17.ebuild
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit versionator toolchain-funcs
6
7 MY_PV=$(replace_all_version_separators '-')
8 MY_P="${PN}-${MY_PV}"
9 DESCRIPTION="Cis-eLement OVERrepresentation: Detection of functional DNA motifs"
10 HOMEPAGE="http://zlab.bu.edu/clover/"
11 SRC_URI="http://zlab.bu.edu/~mfrith/downloads/${MY_P}.tar.gz
12         http://zlab.bu.edu/clover/jaspar2005core"
13
14 LICENSE="as-is"
15 SLOT="0"
16 IUSE=""
17 KEYWORDS="~x86"
18
19 DEPEND=""
20 RDEPEND=""
21
22 S="${WORKDIR}/${MY_P}"
23
24 src_unpack() {
25         unpack ${MY_P}.tar.gz
26         sed -i "s:g++:$(tc-getCXX):; s:-Wall -O3:${CFLAGS}:" Makefile || die "sed failed"
27 }
28
29 src_compile() {
30         emake || die "emake failed"
31 }
32
33 src_install() {
34         dobin clover
35         insinto /usr/share/${PN}
36         doins "${DISTDIR}"/jaspar2005core || die "doins failed"
37 }
38
39 pkg_postinst() {
40         elog "The motif library jaspar2005core has been installed in"
41         elog "    /usr/share/clover/jaspar2005core"
42         elog "You can pass this library to clover for motif search, or use your own library."
43 }