]> Pileus Git - ~andy/sunrise/blob - sci-biology/blat/blat-33.ebuild
sci-biology/blat: new ebuild: sci-biology/blat-33 (bug 135307)
[~andy/sunrise] / sci-biology / blat / blat-33.ebuild
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 DESCRIPTION="The BLAST-Like Alignment Tool, a fast genomic sequence aligner"
6 LICENSE="blat"
7 HOMEPAGE="http://www.cse.ucsc.edu/~kent/"
8 SLOT="0"
9 IUSE=""
10 KEYWORDS="~x86"
11
12 SRC_URI="http://www.soe.ucsc.edu/~kent/src/${PN}Src${PV}.zip"
13 S="${WORKDIR}/${PN}Src"
14
15 DEPEND="app-arch/unzip"
16 RDEPEND=""
17
18 inherit toolchain-funcs
19
20 src_compile() {
21         MACHTYPE=$(tc-arch)
22         if [[ $MACHTYPE == "x86" ]]; then MACHTYPE="i386"; fi
23         sed -i 's/-Werror//; s/CFLAGS=//;' "${S}/inc/common.mk"
24         mkdir -p "${S}/bin/${MACHTYPE}"
25         emake MACHTYPE="${MACHTYPE}" HOME="${S}" || die "emake failed"
26 }
27
28 src_install() {
29         MACHTYPE="`uname|tr 'A-Z' 'a-z'|sed 's/linux/i386/'`"
30         dobin "${S}/bin/${MACHTYPE}/"*
31 }