]> Pileus Git - ~andy/sunrise/blob - sci-biology/amos/amos-2.0.4.ebuild
ac87e66e468f4887197aaa0497efceccfaaacaf0
[~andy/sunrise] / sci-biology / amos / amos-2.0.4.ebuild
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="1"
6 inherit qt3
7
8 DESCRIPTION="A Modular, Open-Source whole genome assembler"
9 HOMEPAGE="http://amos.sourceforge.net/"
10 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 IUSE=""
15 KEYWORDS="~x86"
16
17 DEPEND=">=x11-libs/qt-3.3:3"
18 RDEPEND="${DEPEND}
19         sci-biology/mummer"
20
21 src_compile() {
22         econf || die "econf failed"
23         # TODO: fix parallel make. Notified upstream
24         emake -j1 || die "emake failed"
25 }
26
27 src_install() {
28         emake DESTDIR="${D}" install || die "install failed"
29 }