]> Pileus Git - ~andy/sunrise/blob - net-www/swfdec-mozilla/swfdec-mozilla-0.4.4.ebuild
net-www/swfdec-mozilla: added a trailing slash to a URI and adjusted DESCRIPTION
[~andy/sunrise] / net-www / swfdec-mozilla / swfdec-mozilla-0.4.4.ebuild
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils nsplugins
6
7 DESCRIPTION="A decoder/renderer netscape style plugin for Macromedia Flash animations."
8 HOMEPAGE="http://swfdec.freedesktop.org/"
9 SRC_URI="http://swfdec.freedesktop.org/download/${PN}/${PV:0:3}/${P}.tar.gz"
10 LICENSE="GPL-2"
11 SLOT="0"
12 KEYWORDS="~amd64 ~x86 ~ppc"
13 IUSE=""
14
15 DEPEND=">=media-libs/swfdec-0.4.4
16         || ( www-client/mozilla-firefox www-client/seamonkey )"
17 RDEPEND=""
18
19 src_install() {
20                   exeinto /usr/lib/nsbrowser/plugins
21                   doexe src/.libs/libswfdecmozilla.so || die "libswfdecmozilla.so failed"
22 #                 inst_plugin /usr/lib/nsbrowser/plugins/libswfdecmozilla.so
23
24                   insinto /usr/lib/nsbrowser/plugins
25                   doins src/libswfdecmozilla.la
26 #                 inst_plugin /usr/lib/nsbrowser/plugins/libswfdecmozilla.la
27
28 }
29
30 pkg_postinst() {
31         einfo "Remember to report bugs to: https://bugzilla.freedesktop.org/"
32 }