]> Pileus Git - ~andy/sunrise/blob - net-wireless/rtl818x-svn/rtl818x-svn-20070516.ebuild
Remove, outdated, plus a driver for this included in 2.6.24 vanilla kernel
[~andy/sunrise] / net-wireless / rtl818x-svn / rtl818x-svn-20070516.ebuild
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils linux-mod
6
7 DESCRIPTION="Experimental driver for RTL8187 and RTL818x wireless chipsets"
8 HOMEPAGE="http://rtl-wifi.sourceforge.net/"
9 SRC_URI="http://father.lugmen.org.ar/~aryix/distfiles/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15
16 DEPEND="!net-wireless/ieee80211"
17 RDEPEND="${DEPEND}
18                 net-wireless/wireless-tools"
19
20 MODULE_NAMES="ieee80211_crypt-rtl(net:ieee80211)
21         ieee80211_crypt_wep-rtl(net:ieee80211)
22         ieee80211_crypt_tkip-rtl(net:ieee80211)
23         ieee80211_crypt_ccmp-rtl(net:ieee80211)
24         ieee80211-rtl(net:ieee80211)
25         r8180(net:rtl818x-newstack)
26         r8187(net:rtl8187-newstack)"
27
28 BUILD_TARGETS="all"
29
30 pkg_setup() {
31         if ! kernel_is 2 6 ; then
32                 eerror "This driver is for kernel >=2.6 only!"
33                 die "No kernel >=2.6 detected!"
34         fi
35
36         # Needs WIRELESS_EXT in kernel, for wireless_send_event
37         local CONFIG_CHECK="WIRELESS_EXT CRYPTO CRYPTO_ARC4 CRC32 !IEEE80211"
38         local ERROR_IEEE80211="${P} requires the in-kernel version of the IEEE802.11 subsystem to be disabled (CONFIG_IEEE80211)"
39         linux-mod_pkg_setup
40         BUILD_PARAMS="${KV_DIR} M=\${PWD}"
41 }
42
43 src_install() {
44         linux-mod_src_install
45
46         dodoc ChangeLog
47
48         # Further documentation
49         local d f
50         for d in ieee80211 rtl818x-newstack ; do
51                 docinto "${d}"
52                 for f in AUTHORS CHANGES README{,.adhoc,.master} ; do
53                         [[ -e "${d}/${f}" ]] && dodoc "${d}/${f}"
54                 done
55         done
56 }
57
58 pkg_postinst() {
59         linux-mod_pkg_postinst
60
61         elog "You may want to add the following modules to"
62         elog "/etc/modules.autoload.d/kernel-2.6"
63         elog
64         elog "The r8188 module:                 r8188"
65         elog "The r8187 module:                 r8187"
66         elog "WEP and WPA encryption:   ieee80211_crypt-rtl"
67         elog "WEP encryption:                   ieee80211_crypt_wep-rtl"
68         elog "WPA TKIP encryption:              ieee80211_crypt_tkip-rtl"
69         elog "WPA CCMP encryption:              ieee80211_crypt_ccmp-rtl"
70         elog "For the r8187 module:             ieee80211-rtl"
71 }