]> Pileus Git - ~andy/sunrise/blob - net-wireless/ircp-tray/ircp-tray-0.7.5.ebuild
app-misc/autokey-gtk: Add ~amd64 keyword, EAPI bump
[~andy/sunrise] / net-wireless / ircp-tray / ircp-tray-0.7.5.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=1
6
7 inherit gnome2-utils versionator
8
9 DESCRIPTION="A tray app for wireless OBEX file transfers using IrDA"
10 HOMEPAGE="https://launchpad.net/ircp-tray"
11 SRC_URI="http://launchpad.net/${PN}/$(get_version_component_range 1-2)/${PV}/+download/${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 RDEPEND="dev-libs/openobex
19         x11-libs/gtk+:2
20         x11-libs/libnotify"
21 DEPEND="${RDEPEND}
22         dev-util/intltool
23         virtual/pkgconfig
24         sys-devel/gettext"
25
26 src_install( ) {
27         emake DESTDIR="${D}" install || die
28         dodoc AUTHORS CONTRIBUTORS ChangeLog || die
29 }
30
31 pkg_preinst() {
32         gnome2_icon_savelist
33 }
34
35 pkg_postinst() {
36         gnome2_icon_cache_update
37 }