]> Pileus Git - ~andy/sunrise/blob - net-wireless/coova-chilli/coova-chilli-1.0.11.ebuild
games-board/qbriscola: Fix qt deps, EAPI bump, add ~amd64 keyword
[~andy/sunrise] / net-wireless / coova-chilli / coova-chilli-1.0.11.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils
6
7 MY_PN="CoovaChilli"
8 DESCRIPTION="CoovaChilli is an open-source software access controller, based on
9 the ChilliSpot project."
10 HOMEPAGE="http://www.coova.org/CoovaChilli"
11 SRC_URI="http://ap.coova.org/chilli/${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64"
16 IUSE=""
17
18 src_install() {
19         emake DESTDIR="${D}" install || die "Install failed"
20
21         # We need to overwrite the provided init script
22         doinitd "${FILESDIR}"/chilli || die "doinitd failed"
23
24         dodoc doc/hotspotlogin.cgi "${FILESDIR}"/firewall.iptables || die "dodoc
25         failed"
26 }
27
28 pkg_postinst() {
29         elog "$MY_PN uses RADIUS for access provisioning and accounting so be sure"
30         elog "to install and configure a RADIUS server before using ${MY_PN}."
31         elog "Gentoo-wiki has a nice guide regarding this (uses Freeradius):"
32         elog "  http://en.gentoo-wiki.com/wiki/Chillispot_with_FreeRadius_and_MySQL"
33 }