]> Pileus Git - ~andy/sunrise/blob - net-wireless/btscanner/btscanner-2.1.ebuild
net-wireless/ircp-tray: Version bump with basically rewritten ebuild -- the applicati...
[~andy/sunrise] / net-wireless / btscanner / btscanner-2.1.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils autotools
6
7 DESCRIPTION="Extract information from Bluetooth devices"
8 HOMEPAGE="http://www.pentest.co.uk"
9 SRC_URI="http://www.pentest.co.uk/src/${P}.tar.bz2"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15
16 DEPEND="net-wireless/bluez
17         sys-libs/ncurses
18         dev-lang/perl
19         dev-libs/libxml2"
20 RDEPEND="${DEPEND}"
21
22 src_unpack() {
23         unpack ${A}
24         cd "${S}"
25
26         # Apply patch to strip -Wimplicit-function-dec
27         epatch "${FILESDIR}"/${P}-configure.in.patch
28
29         # Apply patch for moved DTD and oui.txt
30         epatch "${FILESDIR}"/${P}-btscanner.xml.patch
31
32         # Reconfigure
33         eautoreconf
34 }
35
36 src_install() {
37         emake DESTDIR="${D}" install || die "emake install failed"
38
39         # Move DTD file
40         dodir /usr/share/btscanner || die "dodir failed"
41         mv "${D}"/etc/btscanner.dtd "${D}"/usr/share/btscanner
42         mv "${D}"/usr/share/oui.txt "${D}"/usr/share/btscanner
43
44         dodoc AUTHORS README USAGE || die "dodoc failed"
45 }