]> Pileus Git - ~andy/sunrise/blob - net-print/gnome-manual-duplex/gnome-manual-duplex-0.43.ebuild
sci-visualization/tulip: Fix qt deps
[~andy/sunrise] / net-print / gnome-manual-duplex / gnome-manual-duplex-0.43.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 PYTHON_DEPEND="2:2.6"
8
9 inherit eutils multilib python
10
11 MY_PN=${PN/gnome/g}
12
13 DESCRIPTION="Utility that adds manual duplex to the Print menu"
14 HOMEPAGE="http://sourceforge.net/projects/g-manual-duplex/"
15 SRC_URI="mirror://sourceforge/${MY_PN}/${P}.tar.gz"
16
17 LICENSE="GPL-2"
18 SLOT="0"
19 KEYWORDS="~amd64 ~x86"
20 IUSE="gnome"
21
22 RDEPEND="app-text/psutils
23         dev-libs/libgamin[python]
24         dev-python/pycups
25         dev-python/pygobject:2
26         dev-python/pygtk:2
27         sys-apps/file
28         gnome? (
29                 dev-python/gnome-applets-python
30                 gnome-base/gnome-panel[bonobo]
31                 )"
32 DEPEND="${RDEPEND}
33         dev-util/gtk-builder-convert
34         media-gfx/transfig
35         media-libs/netpbm
36         sys-devel/gettext"
37
38 src_prepare() {
39         python_convert_shebangs -r 2 .
40         epatch "${FILESDIR}"/${P}-makefile.patch
41 }
42
43 src_install() {
44         local myinstall
45
46         if use gnome ; then
47                 myinstall="install-gnome"
48         else
49                 myinstall="install"
50         fi
51
52         emake \
53                 DESTDIR="${D}" \
54                 LIBDIR=$(get_libdir) \
55                 DOCDIR=/usr/share/doc/${PF} \
56                 $myinstall
57 }
58
59 pkg_postinst() {
60         if use gnome ; then
61                 elog "Gnome-3 only works in fallback mode."
62         fi
63 }