]> Pileus Git - ~andy/sunrise/blob - net-print/epsoneplijs/epsoneplijs-0.4.1.ebuild
4a367ac7b2fef204297249aa247b2f05d3446545
[~andy/sunrise] / net-print / epsoneplijs / epsoneplijs-0.4.1.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils
6
7 DESCRIPTION="Epson EPL-5x00L/EPL-6x00L Printer Driver for ghostscript"
8 HOMEPAGE="http://sourceforge.net/projects/epsonepl"
9 SRC_URI="mirror://sourceforge/epsonepl/${P}.tgz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="usb"
15
16 DEPEND="net-print/cups
17         virtual/ghostscript
18         net-print/foomatic-filters
19         usb? ( virtual/libusb )"
20 RDEPEND="${DEPEND}"
21
22 src_unpack() {
23         unpack ${A}
24         cd "${S}"
25         epatch "${FILESDIR}/${P}-destdir.patch"
26 }
27
28 src_compile() {
29         econf $(use_with usb libusb)
30         emake || die "emake failed"
31 }
32
33 src_install() {
34         emake DESTDIR="${D}" install || die "emake install failed"
35
36         insinto /usr/share/ppd/
37         doins foomatic_PPDs/* || die "doins failed"
38
39         dodoc ChangeLog FAQ README || die "dodoc failed"
40 }