]> Pileus Git - ~andy/sunrise/blob - net-p2p/transmission-remote-gtk/transmission-remote-gtk-0.5.1.ebuild
net-p2p/transmission-remote-gtk: New ebuild for bug 364721 thanks to floppym, mgorny...
[~andy/sunrise] / net-p2p / transmission-remote-gtk / transmission-remote-gtk-0.5.1.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 inherit gnome2
8
9 DESCRIPTION="GTK client for management of the Transmission BitTorrent client, over HTTP RPC"
10 HOMEPAGE="http://code.google.com/p/transmission-remote-gtk"
11 SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="debug geoip"
17
18 DEPEND="geoip? ( dev-libs/geoip )
19         dev-libs/glib:2
20         >=dev-libs/json-glib-0.12.2
21         dev-libs/libunique
22         gnome-base/gconf
23         net-libs/libproxy
24         net-misc/curl
25         x11-libs/gtk+:2
26         x11-libs/libnotify"
27 RDEPEND="${DEPEND}"
28
29 DOCS="AUTHORS README"
30
31 src_configure() {
32         econf \
33                 $(use_enable debug) \
34                 $(use_with geoip libgeoip)
35 }