]> Pileus Git - ~andy/sunrise/blob - net-p2p/qbittorrent/qbittorrent-0.8.0.ebuild
media-gfx/ipe: New ebuild for bug 80448.
[~andy/sunrise] / net-p2p / qbittorrent / qbittorrent-0.8.0.ebuild
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils qt4
6
7 DESCRIPTION="BitTorrent client in C++ and Qt."
8 HOMEPAGE="http://www.qbittorrent.org/"
9 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15
16 DEPEND=">=net-libs/rb_libtorrent-0.11
17         $(qt4_min_version 4.1)
18         >=dev-lang/python-2.3
19         dev-libs/boost
20         net-misc/curl"
21 RDEPEND="${DEPEND}"
22
23 pkg_setup() {
24         if ! built_with_use dev-libs/boost threads; then
25                 eerror "dev-libs/boost has to be built with threads USE-flag."
26                 die "Missing threads USE-flag for dev-libs/boost"
27         fi
28 }
29
30 src_compile() {
31         # econf fails, since this uses qconf
32         ./configure --prefix=/usr --qtdir=/usr || die "configure failed"
33         emake || die "emake failed"
34 }
35
36 src_install() {
37         emake INSTALL_ROOT="${D}" install || die "emake install failed"
38         dodoc AUTHORS Changelog NEWS README TODO
39 }