]> Pileus Git - ~andy/sunrise/blob - net-p2p/nanodc/nanodc-0.3.3.ebuild
x11-plugins/pidgin-sendscreenshot: Properly fix qt deps
[~andy/sunrise] / net-p2p / nanodc / nanodc-0.3.3.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="4"
6
7 inherit toolchain-funcs versionator
8
9 DESCRIPTION="Ncurses DC++ client"
10 HOMEPAGE="http://sourceforge.net/projects/nanodc/"
11 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~ppc ~x86"
16 IUSE=""
17
18 RDEPEND="
19         sys-libs/ncurses
20         sys-libs/zlib
21         dev-libs/libsigc++:2
22         dev-libs/glib:2"
23 DEPEND="${RDEPEND}
24         dev-util/scons
25         virtual/pkgconfig"
26
27 BIGVERSION=nanodc-$(get_version_component_range 1-2 )
28
29 pkg_setup() {
30         if [[[ gcc-major-version ] != 4 ]]; then
31                 eerror "We need at least gcc-4.0 to compile"
32                 die "gcc-4 required"
33         fi
34 }
35
36 src_compile() {
37         cd "${WORKDIR}/${BIGVERSION}/trunk/src"
38         scons || die "scons failed!"
39 }
40
41 src_install() {
42         dobin "${WORKDIR}/${BIGVERSION}/trunk/src/nanodc"
43 }