]> Pileus Git - ~andy/sunrise/blob - net-p2p/nanodc/nanodc-0.3.3.ebuild
net-p2p/freenet: New upstream release
[~andy/sunrise] / net-p2p / nanodc / nanodc-0.3.3.ebuild
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit toolchain-funcs versionator
6
7 DESCRIPTION="Ncurses DC++ client"
8 HOMEPAGE="http://sourceforge.net/projects/nanodc/"
9 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~ppc ~x86"
14 IUSE=""
15
16 RDEPEND="sys-libs/ncurses
17         sys-libs/zlib
18         >=dev-libs/libsigc++-2.0.0
19         >=dev-libs/glib-2.0.0"
20 DEPEND="${RDEPEND}
21         dev-util/scons
22         dev-util/pkgconfig"
23
24 BIGVERSION=nanodc-$(get_version_component_range 1-2 )
25
26 pkg_setup() {
27         if [[[ gcc-major-version ] != 4 ]]; then
28                 eerror "We need at least gcc-4.0 to compile"
29                 die "gcc-4 required"
30         fi
31 }
32
33 src_compile() {
34         cd "${WORKDIR}/${BIGVERSION}/trunk/src"
35         scons || die "scons failed!"
36 }
37
38 src_install() {
39         dobin "${WORKDIR}/${BIGVERSION}/trunk/src/nanodc"
40 }