]> Pileus Git - ~andy/sunrise/blob - net-p2p/nanodc/nanodc-0.2.2.ebuild
dev-cpp/libvmime: Unneeded inheritance from eclass removed.
[~andy/sunrise] / net-p2p / nanodc / nanodc-0.2.2.ebuild
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit toolchain-funcs versionator
6
7 DESCRIPTION="Ncurses DC++ client"
8 HOMEPAGE="http://sourceforge.net/projects/nanodc/"
9 SRC_URI="http://pouserinet.be/${P}.tar.gz"
10 LICENSE="GPL-2"
11 SLOT="0"
12 KEYWORDS="~amd64 ~x86"
13 IUSE=""
14 DEPEND="app-arch/bzip2
15         sys-libs/ncurses
16         dev-util/pkgconfig
17         dev-util/scons
18         sys-libs/zlib
19         >=dev-libs/libsigc++-2.0.0
20         >=dev-libs/glib-2.0.0"
21 RDEPEND=${DEPEND}
22 BIGVERSION=nanodc-$(get_version_component_range 1-2 )
23
24 pkg_setup() {
25         if [[[ gcc-major-version ] != 4 ]]; then
26                 eerror "We need at least gcc-4.0 to compile"
27                 die "gcc-4 required"
28         fi
29 }
30
31 src_compile() {
32         cd "${WORKDIR}/${BIGVERSION}/trunk/src"
33         scons || die "scons failed!"
34 }
35
36 src_install() {
37         dobin "${WORKDIR}/${BIGVERSION}/trunk/src/nanodc"
38 }