]> Pileus Git - ~andy/sunrise/blob - net-p2p/nanodc/nanodc-0.1_alpha39.ebuild
net-p2p/nanodc: updated changelog
[~andy/sunrise] / net-p2p / nanodc / nanodc-0.1_alpha39.ebuild
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit toolchain-funcs
6
7 DESCRIPTION="Ncurses DC++ client"
8 HOMEPAGE="http://sourceforge.net/projects/nanodc/"
9 SRC_URI="http://secretz.kapsi.fi/cow/${P}.tar.gz"
10 LICENSE="GPL-2"
11 SLOT="0"
12 KEYWORDS="~amd64"
13 IUSE=""
14 DEPEND="app-arch/bzip2
15         sys-libs/ncurses
16         dev-util/pkgconfig
17         dev-util/scons
18         sys-libs/zlib
19         >=dev-libs/libsigc++-2.0.0
20         >=dev-libs/glib-2.0.0"
21 RDEPEND=${DEPEND}
22
23 pkg_setup() {
24         if [[[ gcc-major-version ] != 4 ]]; then
25                 eerror "We need at least gcc-4.0 to compile"
26                 die "gcc-4 required"
27         fi
28 }
29
30 src_compile() {
31         cd "${WORKDIR}"
32         scons || die "scons failed!"
33 }
34
35 src_install() {
36         dobin "${WORKDIR}/nanodc"
37 }