]> Pileus Git - ~andy/sunrise/blob - net-p2p/frost/frost-20080304.ebuild
sci-visualization/tulip: Fix qt deps
[~andy/sunrise] / net-p2p / frost / frost-20080304.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit java-pkg-2 java-ant-2 user
6
7 DESCRIPTION="Message board and file sharing client for freenet network"
8 HOMEPAGE="http://jtcfrost.sourceforge.net/"
9 SRC_URI="http://dev.gentooexperimental.org/~tommy/${P}.tar.bz2"
10 LICENSE="GPL-2"
11 IUSE=""
12 SLOT="0"
13 KEYWORDS="~x86"
14 RDEPEND=">=virtual/jre-1.5
15         net-p2p/freenet"
16 DEPEND=">=virtual/jdk-1.5
17         dev-java/ant"
18 S="${WORKDIR}/frost-wot"
19
20 pkg_setup() {
21         enewgroup frost
22 }
23
24 src_compile() {
25         eant distro
26 }
27
28 src_install() {
29         echo "sh /opt/frost/frost.sh" >frost
30         dobin frost
31         cd build/dist
32         insinto /opt/frost
33         dodoc *txt doc/authors.txt
34         doins frost.sh frost.jar
35         doins -r config downloads exec lib
36         dodir -p /opt/frost/store
37         fowners :frost /usr/bin/frost
38         fperms o-rx /usr/bin/frost
39         fowners -R :frost /opt/frost
40 }
41
42 pkg_postinst() {
43         chmod  g+rw /opt/frost
44         chmod  -R g+rw /opt/frost/config /opt/frost/downloads /opt/frost/store /opt/frost/exec
45         elog "You have to be in the frost-group to start frost."
46         elog "use 'gpasswd -a user frost' to add user to the frost-group."
47 }
48
49 pkg_postrm() {
50         elog "If you dont want to use frost any more"
51         elog "and dont want to keep your identities/other stuff"
52         elog "remember to do 'rm -rf /opt/frost' do remove everything"
53 }