]> Pileus Git - ~andy/sunrise/blob - net-p2p/fms/fms-0.3.21.ebuild
net-p2p/fms: New Ebuild for fms. Thanks to Tommy[D].
[~andy/sunrise] / net-p2p / fms / fms-0.3.21.ebuild
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils cmake-utils
6
7 DESCRIPTION="A spam-resistant message board application for Freenet"
8 HOMEPAGE="http://freenetproject.org/tools.html"
9 SRC_URI="http://individual.utoronto.ca/nezic/${PN}-src-${PV}.zip"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15
16 RDEPEND="net-p2p/freenet
17         virtual/libiconv
18         >=dev-libs/poco-1.2.9
19         dev-db/sqlite"
20
21 S=${WORKDIR}
22
23 pkg_setup() {
24         enewgroup freenet
25         enewuser freenet -1 -1 /var/freenet freenet
26 }
27
28 src_compile() {
29         local mycmakeargs="-DI_HAVE_READ_THE_README=ON
30                 -DUSE_BUNDLED_SQLITE=OFF
31                 -DDO_CHARSET_CONVERSION=ON"
32         cmake-utils_src_compile
33 }
34
35 src_install() {
36         insinto /var/freenet/fms
37         doins ${PN}_build/fms template.htm || die "doinstall failed"
38         insinto /var/freenet/fms/fonts
39         doins fonts/*.bmp || die "doinstall of fonts failed"
40         fperms +x /var/freenet/fms/fms
41         fperms -R o-rwx /var/freenet/fms/
42         fowners -R freenet:freenet /var/freenet/fms/
43         doinitd "${FILESDIR}/fms"
44         dodoc readme.txt
45 }
46
47 pkg_postinst() {
48         elog "By default, the FMS NNTP server will listen on port 1119,"
49         elog "and the web configuration interface will be running at"
50         elog "http://localhost:8080. For more information, readme.txt."
51 }