]> Pileus Git - ~andy/sunrise/blob - net-p2p/NativeThread/NativeThread-20080224.ebuild
net-p2p/freenet: Changed file permissions
[~andy/sunrise] / net-p2p / NativeThread / NativeThread-20080224.ebuild
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils flag-o-matic toolchain-funcs
6
7 DESCRIPTION="NativeThread for priorities on linux for freenet"
8 HOMEPAGE="http://www.freenetproject.org/"
9 SRC_URI="http://dev.gentooexperimental.org/~tommy/${P}.tar.bz2"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~x86"
14 IUSE=""
15
16 DEPEND="net-p2p/freenet"
17
18 append-flags -fPIC
19 tc-getCC >/dev/null
20
21 pkg_setup() {
22         cp ${ROOT}opt/freenet/freenet-cvs-snapshot.jar ${DISTDIR}/
23         chmod 644 ${DISTDIR}/freenet-cvs-snapshot.jar
24 }
25
26
27 src_unpack() {
28         unpack ${A}
29         cp ${DISTDIR}/freenet-cvs-snapshot.jar .
30         epatch "${FILESDIR}"/Makefile.patch
31 }
32
33 src_install() {
34         into /opt/freenet
35         dolib.so libNativeThread.so
36 }