]> Pileus Git - ~andy/sunrise/blob - net-nntp/nzbperl/nzbperl-0.6.8.ebuild
New ebuild for nzbperl, thanks to Ben Kohler (ben@bkohler.net), bug #124582
[~andy/sunrise] / net-nntp / nzbperl / nzbperl-0.6.8.ebuild
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils
6
7 DESCRIPTION="nzb based nntp/usenet downloader in perl"
8 HOMEPAGE="http://noisybox.net/computers/nzbperl"
9 SRC_URI="${HOMEPAGE}/${P}.pl"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="ipv6 ssl"
15
16 DEPEND="dev-lang/perl
17         app-text/uudeview
18         perl-core/Time-HiRes
19         perl-core/Getopt-Long
20         dev-perl/TermReadKey
21         dev-perl/Term-ANSIColor
22         dev-perl/XML-DOM
23         ssl? ( dev-perl/IO-Socket-SSL )
24         ipv6? ( dev-perl/IO-Socket-INET6 )
25 "
26
27 src_install() {
28         newbin ${DISTDIR}/${P}.pl ${PN}
29         dodoc ${FILESDIR}/${PN}rc.sample
30 }
31
32 pkg_postinst() {
33         if ! built_with_use dev-lang/perl ithreads; then
34                 ewarn "WARNING: dev-lang/perl was built with ithreads disabled, please start nzbperl"
35                 ewarn "with --dthreadct 0 to use single-threaded nzbperl OR remerge dev-lang/perl"
36                 ewarn "with ithreads in your USE flags."
37                 ewarn ""
38                 ewarn "Note that using --dthreadct 0 will cause downloads to pause during decoding,"
39                 ewarn "so it is recommended that you build perl with ithreads enabled."
40         fi
41
42         einfo "A sample config file has been copied into /usr/share/doc/${PF}"
43         einfo "You may want to take it as a sample for your ~/.nzbperlrc"
44 }