]> Pileus Git - ~andy/sunrise/blob - net-nntp/nzbperl/nzbperl-0.6.8.ebuild
sunrise/app-portage/elog-list/elog-list-0.0.6.ebuild: change headers to make repoman...
[~andy/sunrise] / net-nntp / nzbperl / nzbperl-0.6.8.ebuild
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils
6
7 DESCRIPTION="nzb based nntp/usenet downloader in perl"
8 HOMEPAGE="http://noisybox.net/computers/nzbperl/"
9 SRC_URI="http://noisybox.net/computers/nzbperl/${P}.pl"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="ipv6 ssl"
15
16 DEPEND="dev-lang/perl
17         app-text/uudeview
18         virtual/perl-Time-HiRes
19         virtual/perl-Getopt-Long
20         dev-perl/TermReadKey
21         dev-perl/Term-ANSIColor
22         dev-perl/XML-DOM
23         ssl? ( dev-perl/IO-Socket-SSL )
24         ipv6? ( dev-perl/IO-Socket-INET6 )
25 "
26
27 src_unpack() {
28         :
29 }
30
31 src_install() {
32         newbin "${DISTDIR}/${P}.pl" ${PN}
33         dodoc "${FILESDIR}/${PN}rc.sample"
34 }
35
36 pkg_postinst() {
37         if ! built_with_use dev-lang/perl ithreads; then
38                 ewarn "WARNING: dev-lang/perl was built with ithreads disabled, please start nzbperl"
39                 ewarn "with --dthreadct 0 to use single-threaded nzbperl OR remerge dev-lang/perl"
40                 ewarn "with ithreads in your USE flags."
41                 ewarn ""
42                 ewarn "Note that using --dthreadct 0 will cause downloads to pause during decoding,"
43                 ewarn "so it is recommended that you build perl with ithreads enabled."
44         fi
45
46         elog "A sample config file has been copied into /usr/share/doc/${PF}"
47         elog "You may want to take it as a sample for your ~/.nzbperlrc"
48 }