]> Pileus Git - ~andy/sunrise/blob - net-news/feed2imap/feed2imap-1.0.ebuild
sci-visualization/tulip: Fix qt deps
[~andy/sunrise] / net-news / feed2imap / feed2imap-1.0.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6 USE_RUBY="ruby18"
7
8 inherit ruby-ng
9
10 DESCRIPTION="RSS/Atom feed aggregator which uploads feeds to an IMAP server"
11 HOMEPAGE="http://home.gna.org/feed2imap/"
12 SRC_URI="http://download.gna.org/${PN}/${P}.tgz"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE=""
18
19 RDEPEND="dev-ruby/ruby-feedparser
20         dev-ruby/rubymail"
21
22 each_ruby_configure() {
23         ${RUBY} setup.rb config || die
24 }
25
26 each_ruby_install() {
27         ${RUBY} setup.rb install --prefix="${D}" || die
28 }
29
30 all_ruby_install() {
31         dodoc ChangeLog README || die
32 }