]> Pileus Git - ~andy/sunrise/blob - net-nds/lat/lat-1.1.6.ebuild
1a47db229784a68c15b487276ab12701a12ac58c
[~andy/sunrise] / net-nds / lat / lat-1.1.6.ebuild
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils gnome2 mono
6
7 KEYWORDS="~amd64 ~x86"
8
9 DESCRIPTION="LDAP Administration Tool, allows you to browse LDAP-based directories and add/edit/delete entries."
10 HOMEPAGE="http://dev.mmgsecurity.com/projects/lat"
11 SRC_URI="http://dev.mmgsecurity.com/downloads/${PN}/1.1/${P}.tar.gz"
12 LICENSE="GPL-2"
13 IUSE="avahi"
14 SLOT="0"
15
16 RDEPEND=">=dev-lang/mono-1.1.13
17                 =dev-dotnet/gtk-sharp-2.8*
18                 =dev-dotnet/gnome-sharp-2.8*
19                 =dev-dotnet/glade-sharp-2.8*
20                 =dev-dotnet/gconf-sharp-2.8*
21                 =gnome-base/gnome-keyring-0.4*
22                 sys-apps/dbus
23                 avahi? ( net-dns/avahi )"
24 DEPEND="${RDEPEND}
25                 app-text/scrollkeeper
26                 dev-util/pkgconfig"
27
28 src_unpack() {
29         unpack ${A}
30         cd "${S}"
31         epatch "${FILESDIR}/${P}-service_finder_cs.patch"
32 }
33
34 src_compile() {
35         econf \
36                 $(use_enable avahi) \
37                 || die "econf failed"
38         emake || die "emake failed"
39 }
40
41 src_install() {
42         emake DESTDIR="${D}" install || die "emake install failed"
43         dodoc AUTHORS ChangeLog NEWS README TODO
44 }