]> Pileus Git - ~andy/sunrise/blob - net-misc/x-lite/x-lite-2.0.1105d.ebuild
removing net-misc/vidalia from sunrise as it was added to portage
[~andy/sunrise] / net-misc / x-lite / x-lite-2.0.1105d.ebuild
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils
6
7 DESCRIPTION="CounterPath X-Lite - a free closed-source SIP Softphone Client for Linux"
8 HOMEPAGE="http://www.counterpath.net/index.php"
9 SRC_URI="http://www.counterpath.net/download/X-Lite_Install.tar.gz"
10
11 LICENSE="as-is"
12 SLOT="0"
13 KEYWORDS="~x86"
14 IUSE=""
15 RESTRICT="strip"
16
17 RDEPEND="dev-libs/atk
18         dev-libs/glib
19         dev-libs/libxml2
20         gnome-base/libglade
21         x11-libs/gtk+
22         || ( x11-libs/libX11 <virtual/x11-7.0 )
23         x11-libs/pango
24         sys-libs/zlib
25         amd64? ( >=app-emulation/emul-linux-x86-baselibs-2.4.1
26                  >=app-emulation/emul-linux-x86-xlibs-2.2.2
27                  >=app-emulation/emul-linux-x86-compat-1.0-r1
28                  >=app-emulation/emul-linux-x86-gtklibs-2.3 )"
29
30 S=${WORKDIR}/xten-xlite
31
32 pkg_setup() {
33         has_multilib_profile && ABI="x86"
34 }
35
36 src_install() {
37         local dir="/opt/x-lite"
38         exeinto "${dir}"
39         doexe xtensoftphone
40
41         dodir /opt/bin
42         dosym ${dir}/xtensoftphone /opt/bin/xtensoftphone
43
44         make_desktop_entry xtensoftphone X-Lite
45         doicon "${FILESDIR}/x-lite.png"
46
47         dodoc README
48 }
49
50 pkg_postinst() {
51         elog
52         elog "Warning: this is still a beta release!"
53         elog "If you need support please browse counterpath's forums:"
54         elog "http://support.counterpath.com/"
55         elog
56 }