]> Pileus Git - ~andy/sunrise/blob - net-misc/vidalia/vidalia-0.0.6.ebuild
net-misc/vidalia: Initial ebuild (vidalia-0.0.6) for bug #138893
[~andy/sunrise] / net-misc / vidalia / vidalia-0.0.6.ebuild
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils
6
7 DESCRIPTION="Qt 4 front-end for Tor"
8 HOMEPAGE="http://www.vidalia-project.net/"
9 SRC_URI="http://www.vidalia-project.net/dist/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~x86"
14 IUSE="debug"
15
16 DEPEND=">=x11-libs/qt-4.1.1"
17 RDEPEND="$(DEPEND)
18         >=net-misc/tor-0.1.1.20"
19
20 pkg_setup() {
21         if use debug && ! built_with_use ">=x11-libs/qt-4.1.1" debug  ; then
22                 eerror "In order to have debug support for Vidalia"
23                 eerror "you need to compile Qt 4 with debug support too."
24                 die "Qt 4 built without debug support"
25         fi
26 }
27
28 src_compile() {
29         econf $(use_enable debug) || die "econf failed"
30
31         emake || die "emake failed"
32 }
33
34 src_install() {
35         emake INSTALL_ROOT="${D}" install || die "emake install failed"
36 }