]> Pileus Git - ~andy/sunrise/blob - net-misc/tucan/tucan-9999.ebuild
net-misc/tucan: Reverted back to doicon, my bad
[~andy/sunrise] / net-misc / tucan / tucan-9999.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 inherit eutils subversion
8
9 ESVN_REPO_URI="https://forja.rediris.es/svn/cusl3-tucan/trunk/"
10 ESVN_PROJECT="tucan-svn"
11 ESVN_STORE_DIR="${D}/svn-src"
12
13 DESCRIPTION="Manages automatically downloads and uploads from one-click hosting sites like RapidShare"
14 HOMEPAGE="http://tucaneando.com/"
15 SRC_URI="http://forja.rediris.es/frs/download.php/1470/${P}.tar.gz"
16
17 LICENSE="GPL-3"
18 SLOT="0"
19 KEYWORDS=""
20 IUSE="gtk"
21
22 RDEPEND="dev-lang/python
23         gtk? ( dev-python/pygtk
24                 gnome-base/librsvg )
25         app-text/tesseract[linguas_en]
26         dev-python/imaging"
27
28 src_install() {
29         emake DESTDIR="${D}"/usr install || die "emake install failed"
30         dodoc CHANGELOG README || die "dodoc failed"
31         if use gtk ; then
32                 doicon media/tucan.svg || die "doicon failed"
33                 make_desktop_entry tucan Tucan
34         fi
35 }