]> Pileus Git - ~andy/sunrise/blob - net-misc/tucan/tucan-9999.ebuild
dev-util/lvprog: Properly fix qt deps
[~andy/sunrise] / net-misc / tucan / tucan-9999.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 inherit eutils subversion
8
9 # There's no other way to checkout the repository.
10 # The certificated used by https protocol is provided by
11 # GTE CyberTrust Global Root (ca-certificates).
12 ESVN_REPO_URI="https://forja.rediris.es/svn/cusl3-tucan/trunk/"
13
14 DESCRIPTION="Manages automatic downloads and uploads from one-click hosting sites like RapidShare"
15 HOMEPAGE="http://tucaneando.com/"
16 SRC_URI=""
17
18 LICENSE="GPL-3"
19 SLOT="0"
20 KEYWORDS=""
21 IUSE="gtk"
22
23 RDEPEND="dev-lang/python
24         gtk? ( dev-python/pygtk
25                 gnome-base/librsvg )
26         app-text/tesseract
27         dev-python/imaging"
28
29 src_install() {
30         emake DESTDIR="${D}"/usr install || die "emake install failed"
31         dodoc CHANGELOG README || die "dodoc failed"
32         if use gtk ; then
33                 doicon media/tucan.svg || die "doicon failed"
34                 make_desktop_entry tucan Tucan
35         fi
36 }