]> Pileus Git - ~andy/sunrise/blob - net-misc/tucan/tucan-0.3.9.ebuild
app-admin/noobjuice-gentoo: Fix qt deps, EAPI bump
[~andy/sunrise] / net-misc / tucan / tucan-0.3.9.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 inherit eutils
8
9 DESCRIPTION="Manages automatic downloads and uploads from one-click hosting sites like RapidShare"
10 HOMEPAGE="http://tucaneando.com/"
11 SRC_URI="http://forja.rediris.es/frs/download.php/1470/${P}.tar.gz"
12
13 LICENSE="GPL-3"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="gtk"
17
18 RDEPEND="dev-lang/python
19         gtk? ( dev-python/pygtk
20                 gnome-base/librsvg )
21         app-text/tesseract
22         dev-python/imaging"
23
24 src_compile() { :; }
25
26 src_install() {
27         emake DESTDIR="${D}"/usr install || die "emake install failed"
28         dodoc CHANGELOG README || die "dodoc failed"
29         if use gtk ; then
30                 doicon media/tucan.svg || die "doicon failed"
31                 make_desktop_entry tucan Tucan
32         fi
33 }
34
35 pkg_postinst() {
36         if ! use gtk ; then
37                 ewarn "Please be aware that Tucan curses interface is still under"
38                 ewarn "development."
39                 ewarn
40                 ewarn "You should use 'tucan --cli' for curses interface or"
41                 ewarn "simply use 'tucan --daemon' to use it daemonized."
42         fi
43 }