]> Pileus Git - ~andy/sunrise/blob - net-misc/teardrop/teardrop-1.1.1.ebuild
net-misc/teardrop: Fix wxGTK handling, ebuild cleanup
[~andy/sunrise] / net-misc / teardrop / teardrop-1.1.1.ebuild
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 WX_GTK_VER=2.6
6 inherit wxwidgets
7
8 DESCRIPTION="query multiple search engines at the same time"
9 HOMEPAGE="http://olivier.coupelon.free.fr/teardrop/"
10 SRC_URI="http://olivier.coupelon.free.fr/${PN}/download/${P}.tar.bz2"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~x86"
15 IUSE="unicode"
16
17 DEPEND="virtual/libiconv
18         dev-libs/libxml2
19         net-misc/curl
20         dev-libs/libpcre
21         =x11-libs/wxGTK-2.6*"
22 RDEPEND="${DEPEND}"
23
24 src_compile() {
25         use unicode && need-wxwidgets unicode || need-wxwidgets gtk2
26
27         econf --with-wx-config="${WX_CONFIG}"
28         emake || die "emake failed"
29 }
30
31 src_install() {
32         emake DESTDIR="${D}" install || die "emake install failed"
33         dodoc ChangeLog
34 }