]> Pileus Git - ~andy/sunrise/blob - net-misc/sslh/sslh-1.6i.ebuild
9825441280a1bafd9daa9900a31501b084b6a5b5
[~andy/sunrise] / net-misc / sslh / sslh-1.6i.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 inherit toolchain-funcs
8
9 DESCRIPTION="SSLH lets one accept both HTTPS and SSH connections on the same port"
10 HOMEPAGE="http://www.rutschle.net/tech/sslh.shtml"
11 SRC_URI="http://www.rutschle.net/tech/${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~x86"
16 IUSE=""
17
18 RDEPEND="net-libs/libnet"
19 DEPEND="${RDEPEND}
20         dev-lang/perl"
21
22 src_prepare() {
23         sed -e "/^USELIBWRAP=1/d" \
24                 -e "/strip sslh/d" \
25                 -e "s/\(\$(LIBS)\)$/\1 ${LDFLAGS}/" -i Makefile || die "sed failed"
26 }
27
28 src_compile() {
29         emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "emake failed"
30 }
31
32 src_install() {
33         dobin sslh || die "dobin failed"
34         doman sslh.8.gz || die "doman failed"
35
36         newinitd "${FILESDIR}"/sslh.init sslh
37         newconfd "${FILESDIR}"/sslh.conf sslh
38 }