]> Pileus Git - ~andy/sunrise/blob - net-misc/sshmenu/sshmenu-3.18.ebuild
net-misc/sshmenu: Version bump, thanks to dilfridge
[~andy/sunrise] / net-misc / sshmenu / sshmenu-3.18.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6 USE_RUBY="ruby18 ruby19"
7
8 inherit multilib ruby-ng
9
10 DESCRIPTION="A gnome applet interface to SSH"
11 HOMEPAGE="http://sshmenu.sourceforge.net"
12 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
13
14 LICENSE="BSD"
15 SLOT="0"
16 KEYWORDS="~x86"
17 IUSE="gnome"
18
19 RUBY_PATCHES=( ${P}-fixmultilib.patch )
20
21 RDEPEND="!gnome? ( net-misc/x11-ssh-askpass )"
22
23 ruby_add_rdepend gnome "dev-ruby/ruby-gconf2 dev-ruby/ruby-panel-applet2"
24 ruby_add_rdepend ">=dev-ruby/ruby-gtk2-0.19.3"
25
26 all_ruby_install() {
27         emake LIBDIR="$(get_libdir)" DESTDIR="${D}" install || die "Install failed!"
28 }