]> Pileus Git - ~andy/sunrise/blob - net-misc/sambascanner/sambascanner-0.22.ebuild
net-misc/esniper: Update to 2.25.0 to handle changes to ebay login.
[~andy/sunrise] / net-misc / sambascanner / sambascanner-0.22.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6
7 inherit autotools eutils toolchain-funcs
8
9 MY_P="SambaScanner-${PV}"
10 DESCRIPTION="a tool to search a whole samba network for files"
11 HOMEPAGE="http://www.johannes-bauer.com/software/sambascanner/"
12 SRC_URI="http://www.johannes-bauer.com/software/${PN}/${MY_P}.tar.bz2"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE="debug linguas_de"
18
19 RDEPEND=">=net-fs/samba-3"
20 DEPEND="${RDEPEND}
21         sys-devel/gettext"
22
23 S=${WORKDIR}/${MY_P}
24
25 src_prepare() {
26         if use debug; then
27                 #prevent configure from completely replacing our CFLAGS
28                 sed -i \
29                         -e 's:CFLAGS="-O0 -g -pthread":CFLAGS="${CFLAGS} -g -pthread":' \
30                         configure.ac || die
31                 eautoreconf
32         fi
33 }
34
35 src_configure() {
36         econf CFLAGS="${CFLAGS} -pthread" $(use_enable debug)
37 }
38
39 src_compile() {
40         emake CC=$(tc-getCC) || die "emake failed"
41 }
42
43 src_install() {
44         # sambascanner's make install is broken
45         dobin src/sambascanner bin/sambaretrieve src/smblister || die
46         insinto /usr/share/${PN}/
47         doins -r db || die
48         use linguas_de && domo i18n/de.mo
49         dodoc AUTHORS ChangeLog README sambascannerrc-example db/db.conf.sample || die
50 }