]> Pileus Git - ~andy/sunrise/blob - net-misc/netbrake/netbrake-0.2.ebuild
app-misc/autokey-gtk: Adding ~amd64 keyword
[~andy/sunrise] / net-misc / netbrake / netbrake-0.2.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils
6
7 DESCRIPTION="A utility to limit the bandwidth used by a process."
8 HOMEPAGE="http://www.hping.org/netbrake/"
9 SRC_URI="http://www.hping.org/${PN}/${P}.tar.gz"
10
11 LICENSE="MIT BSD GPL-2"
12 SLOT="0"
13 KEYWORDS="~x86"
14 IUSE="httpfs"
15
16 S=${WORKDIR}/${PN}
17
18 src_unpack() {
19         unpack ${A}
20         cd "${S}"
21
22         # Makefile.in ignores our compiler and compiler flags preference
23         epatch "${FILESDIR}/${P}-fix-compiler-and-flags.patch"
24
25         # patch to configure files to install the library and script
26         # executable according to gentoo's standards and remove user
27         # interaction for compile options
28         epatch "${FILESDIR}/${P}-fix-path-and-httpfs.patch"
29
30         use httpfs && export HTTPFS_FLAG=y
31 }
32
33 src_install() {
34         dolib libnetbrake.so.0.1 || die "dolib failed"
35         dobin netbrake || die "dobin failed"
36
37         dodoc AUTHORS CHANGES README THANKS TODO || die "dodoc failed"
38 }