]> Pileus Git - ~andy/sunrise/blob - net-misc/iplist/iplist-9999.ebuild
sunrise/ net-nntp/nzbperl/Manifest: Update copyright line to satisfy repoman
[~andy/sunrise] / net-misc / iplist / iplist-9999.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit git-2 linux-info
6
7 EGIT_REPO_URI="git://${PN}.git.sourceforge.net/gitroot/${PN}"
8 EGIT_PROJECT="${PN}"
9 EGIT_PATCHES=( "${FILESDIR}/${PN}-makefile.patch" )
10
11 DESCRIPTION="Blocks connections from/to hosts listed in files using iptables."
12 HOMEPAGE="http://iplist.sourceforge.net/"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS=""
17 IUSE="java"
18 DEPEND="net-firewall/iptables
19         net-libs/libnetfilter_queue
20         net-libs/libnfnetlink
21         sys-libs/zlib"
22 RDEPEND="java? ( >=virtual/jre-1.5 )
23         ${DEPEND}"
24 CONFIG_CHECK="NETFILTER_XT_MATCH_IPRANGE"
25
26 src_install() {
27         if use java ; then
28                 insinto "/usr/share/${PN}"
29                 doins ipblockUI.jar || die "gui install failed"
30         fi
31         emake DESTDIR="${D}" install || die "install failed!"
32         doman {${PN},ipblock}.8 || die "doman failed!"
33         exeinto /etc/cron.daily
34         newexe debian/ipblock.cron.daily ipblock || die "cron failed"
35 }
36
37 pkg_postinst() {
38         einfo "a cron file was set in /etc/cron.daily"
39         einfo "and it will update your lists once a day"
40 }