]> Pileus Git - ~andy/sunrise/blob - net-misc/gns3/gns3-0.7.2.ebuild
net-misc/danbooru-grabber: Tested on x86, thanks to miniBill. Also removed distfile...
[~andy/sunrise] / net-misc / gns3 / gns3-0.7.2.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6
7 PYTHON_DEPEND="2"
8
9 inherit eutils python distutils
10
11 MY_P=${P/gns/GNS}-src
12
13 DESCRIPTION="Graphical Network Simulator"
14 HOMEPAGE="http://www.gns3.net/"
15 SRC_URI="mirror://sourceforge/gns-3/${MY_P}.tar.bz2"
16
17 LICENSE="GPL-2"
18 SLOT="0"
19 KEYWORDS="~amd64 ~x86"
20 IUSE=""
21
22 DEPEND=">=dev-python/PyQt4-4.6.1
23         x11-libs/qt-gui:4
24         x11-libs/qt-svg:4"
25 RDEPEND="${DEPEND}
26         >=app-emulation/dynamips-0.2.8_rc2"
27
28 S=${WORKDIR}/${MY_P}
29
30 pkg_setup() {
31         python_set_active_version 2
32         python_pkg_setup
33 }
34
35 src_prepare() {
36         epatch "${FILESDIR}/${P}_set_dynamips_path.patch"
37         epatch "${FILESDIR}/${P}_set_qemu_path.patch"
38
39         python_convert_shebangs -r 2 .
40
41         distutils_src_prepare
42 }
43
44 src_install() {
45         distutils_src_install
46
47         insinto /usr/libexec/${PN}
48         doins qemuwrapper/{pemubin,qemuwrapper}.py || die
49
50         doicon "${FILESDIR}"/${PN}.xpm
51         make_desktop_entry ${PN} "GNS3" ${PN} "Utility;Emulator"
52
53         doman docs/man/${PN}.1 || die
54 }