]> Pileus Git - ~andy/sunrise/blob - net-misc/gns3/gns3-0.6.ebuild
4697ed15e3991fb49c42586bfaba40bce28692b1
[~andy/sunrise] / net-misc / gns3 / gns3-0.6.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="1"
6
7 inherit distutils
8
9 MY_P=${P/gns/GNS}-src
10
11 DESCRIPTION="Graphical Network Simulator"
12 HOMEPAGE="http://www.gns3.net/"
13 SRC_URI="mirror://sourceforge/gns-3/${MY_P}.tar.bz2"
14
15 LICENSE="GPL-2"
16 SLOT="0"
17 KEYWORDS="~x86"
18 IUSE=""
19
20 DEPEND="x11-libs/qt-gui:4
21         x11-libs/qt-svg:4
22         >=dev-python/PyQt4-4.1"
23
24 RDEPEND="${DEPEND}
25         >=app-emulation/dynamips-0.2.8_rc2"
26
27 S=${WORKDIR}/${MY_P}
28
29 src_unpack() {
30         unpack ${A}
31         cd "${S}"
32         epatch "${FILESDIR}/${P}_set_dynamips_path.patch"
33         epatch "${FILESDIR}/${P}_set_pemu_path.patch"
34 }
35
36 src_install() {
37         distutils_src_install
38         doman docs/man/${PN}.1 || die "Installing man pages failed"
39         insinto /usr/libexec/${PN}
40         doins "${S}/pemu/pemuwrapper.py" || die "Failed to install pemuwrapper.py"
41 }
42