]> Pileus Git - ~andy/sunrise/blob - net-misc/gns3/gns3-0.6.1.ebuild
sunrise/ app-portage/elog-list/elog-list-0.0.6.ebuild: Update headers for 2010
[~andy/sunrise] / net-misc / gns3 / gns3-0.6.1.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="1"
6
7 inherit distutils eutils
8
9 MY_P=${P/gns/GNS}-src
10
11 DESCRIPTION="Graphical Network Simulator"
12 HOMEPAGE="http://www.gns3.net/"
13 SRC_URI="mirror://sourceforge/gns-3/${MY_P}.tar.bz2"
14
15 LICENSE="GPL-2"
16 SLOT="0"
17 KEYWORDS="~x86"
18 IUSE=""
19
20 DEPEND="x11-libs/qt-gui:4
21         x11-libs/qt-svg:4
22         >=dev-python/PyQt4-4.1"
23 RDEPEND="${DEPEND}
24         >=app-emulation/dynamips-0.2.8_rc2"
25 S=${WORKDIR}/${MY_P}
26
27 src_unpack() {
28         unpack ${A}
29         cd "${S}"
30         epatch "${FILESDIR}/${P}_set_dynamips_path.patch"
31         epatch "${FILESDIR}/${P}_set_pemu_path.patch"
32 }
33
34 src_install() {
35         distutils_src_install
36         doman docs/man/${PN}.1 || die "Installing man pages failed"
37         insinto /usr/libexec/${PN}
38         doins "${S}/pemu/pemuwrapper.py" || die "Failed to install pemuwrapper.py"
39 }