]> Pileus Git - ~andy/sunrise/blob - net-misc/freerdp/freerdp-9999.ebuild
c1e88f912dc842f418d1cc7e664f7d6599a28d79
[~andy/sunrise] / net-misc / freerdp / freerdp-9999.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6 WANT_AUTOMAKE="1.11"
7 EGIT_BOOTSTRAP="eautoreconf"
8
9 inherit autotools base git
10
11 EGIT_REPO_URI="git://${PN}.git.sourceforge.net/gitroot/${PN}/${PN}"
12
13 DESCRIPTION="A Remote Desktop Protocol Client, forked from rdesktop"
14 HOMEPAGE="http://www.freerdp.com/"
15 SRC_URI=""
16
17 LICENSE="GPL-2"
18 SLOT="0"
19 KEYWORDS=""
20 IUSE="alsa cups debug gnutls iconv ipv6 largefile libsamplerate nss polarssl \
21 ssl X"
22
23 DEPEND="
24         x11-libs/libX11
25         ssl? ( >=dev-libs/openssl-0.9.8a )
26         nss? ( dev-libs/nss )
27         gnutls? ( >=net-libs/gnutls-2.10.1 )
28         polarssl? ( >=net-libs/polarssl-0.14.0 )
29         alsa? ( media-libs/alsa-lib )
30         libsamplerate? ( media-libs/libsamplerate )
31         cups? ( net-print/cups )
32         iconv? ( virtual/libiconv )"
33 RDEPEND="${DEPEND}"
34
35 DOCS=( AUTHORS ChangeLog NEWS README )
36
37 pkg_setup() {
38         MY_CRYPTOBACKEND="simple"
39         if use polarssl; then
40                 MY_CRYPTOBACKEND="polarssl"
41         fi
42         if use nss; then
43                 if [[ "${MY_CRYPTOBACKEND}" != "simple" ]]; then
44                         ewarn "You have enabled ${MY_CRYPTOBACKEND} and nss."
45                         ewarn "Only one will be selected"
46                 fi
47                 MY_CRYPTOBACKEND="nss"
48         fi
49         if use gnutls; then
50                 if [[ "${MY_CRYPTOBACKEND}" != "simple" ]]; then
51                         ewarn "You have enabled ${MY_CRYPTOBACKEND} and gnutls."
52                         ewarn "Only one will be selected"
53                 fi
54                 MY_CRYPTOBACKEND="gnutls"
55         fi
56         if use ssl; then
57                 if [[ "${MY_CRYPTOBACKEND}" != "simple" ]]; then
58                         ewarn "You have enabled ${MY_CRYPTOBACKEND} and openssl."
59                         ewarn "Only one will be selected"
60                 fi
61                 MY_CRYPTOBACKEND="openssl"
62         fi
63
64         einfo "The selected crypto-backend is: ${MY_CRYPTOBACKEND}"
65
66         if ! use ssl; then
67                 ewarn "You do not have OpenSSL as the crypto-backend,"
68                 ewarn "TLS-connections will not be available."
69                 ewarn "TLS-connectios currently need OpenSSL as crypto-backend."
70         fi
71 }
72
73 src_configure() {
74         # chipcard and directfb are configurable according to ./configure
75         # but they are currently not usable...
76         econf \
77                 --with-crypto="${MY_CRYPTOBACKEND}" \
78                 $(use_enable ssl tls) \
79                 $(use_with debug) \
80                 $(use_with debug debug-channel) \
81                 $(use_with debug debug-kbd) \
82                 $(use_with debug debug-rdp5) \
83                 $(use_with debug debug-serial) \
84                 $(use_with debug debug-sound) \
85                 $(use_with alsa sound alsa) \
86                 $(use_with cups printer cups) \
87                 $(use_enable iconv) \
88                 $(use_enable ipv6) \
89                 $(use_enable largefile) \
90                 $(use_with libsamplerate) \
91                 $(use_with X x)
92 }