]> Pileus Git - ~andy/sunrise/blob - net-misc/freerdp/freerdp-0.7.4.ebuild
sunrise/ net-misc/vpncwatch: Remove net-misc/vpncwatch. Currently in Portage.
[~andy/sunrise] / net-misc / freerdp / freerdp-0.7.4.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6
7 inherit base versionator
8
9 DESCRIPTION="A Remote Desktop Protocol Client, forked from rdesktop"
10 HOMEPAGE="http://freerdp.sourceforge.net/"
11 SRC_URI="mirror://sourceforge/${PN}/$(get_version_component_range 1-2)/${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64"
16 IUSE="alsa cups iconv ipv6 largefile X"
17
18 DEPEND="
19         >=dev-libs/openssl-0.9.8a
20         x11-libs/libX11
21         alsa? ( media-libs/alsa-lib )
22         cups? ( net-print/cups )
23         iconv? ( virtual/libiconv )"
24 RDEPEND="${DEPEND}"
25
26 DOCS=( AUTHORS ChangeLog NEWS README )
27
28 src_configure() {
29         # openssl is mandatory for now. Building without it 
30         # is strongly discouraged according to upstream.
31         # Warning: Do not trust "./configure --help"
32         # it's wrong sometimes - esp. in --enable/--with parts...
33         econf \
34                 --with-crypto=openssl \
35                 $(use_with alsa sound alsa) \
36                 $(use_with cups printer cups) \
37                 $(use_enable iconv) \
38                 $(use_enable ipv6) \
39                 $(use_enable largefile) \
40                 $(use_with X x)
41 }