]> Pileus Git - ~andy/sunrise/blob - net-misc/flexget/flexget-9999.ebuild
[kde-misc/kdirstat] New ebuild for KDE4.
[~andy/sunrise] / net-misc / flexget / flexget-9999.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="3"
6
7 PYTHON_DEPEND="2:2.5"
8 SUPPORT_PYTHON_ABIS="1"
9 RESTRICT_PYTHON_ABIS="2.4 3.*"
10 DISTUTILS_SRC_TEST="setup.py"
11
12 inherit distutils eutils subversion
13
14 DESCRIPTION="A multipurpose automation tool for content like torrents, nzbs, podcasts, comics, etc."
15 HOMEPAGE="http://flexget.com/"
16 SRC_URI=""
17 ESVN_REPO_URI="http://svn.flexget.com/trunk"
18
19 LICENSE="MIT"
20 SLOT="0"
21 KEYWORDS=""
22 IUSE=""
23
24 RDEPEND="dev-python/setuptools
25         dev-python/feedparser
26         >=dev-python/sqlalchemy-0.7
27         dev-python/pyyaml
28         dev-python/beautifulsoup
29         dev-python/html5lib
30         dev-python/jinja
31         dev-python/PyRSS2Gen
32         dev-python/pynzb
33         dev-python/progressbar
34         dev-python/flask
35         dev-python/cherrypy"
36 DEPEND="${RDEPEND}
37         dev-python/paver
38         test? ( dev-python/nose )"
39
40 src_prepare() {
41         # Prevent setup from grabbing nose from pypi
42         sed -e /setup_requires/d -i pavement.py || die
43
44         # Generate setup.py
45         paver generate_setup || die
46
47         epatch_user
48         distutils_src_prepare
49 }