]> Pileus Git - ~andy/sunrise/blob - net-misc/esniper/esniper-2.24.0.ebuild
net-misc/flexget: Version bump. This release installs the webui modules.
[~andy/sunrise] / net-misc / esniper / esniper-2.24.0.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6
7 inherit versionator
8
9 MY_P=${PN}-$(replace_all_version_separators '-')
10 DESCRIPTION="A simple, lightweight tool for sniping ebay auctions"
11 HOMEPAGE="http://esniper.sourceforge.net/"
12 SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tgz"
13
14 LICENSE="BSD"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE=""
18
19 DEPEND="dev-libs/openssl
20         >=net-misc/curl-7.12[ssl]"
21 RDEPEND="${DEPEND}"
22
23 S=${WORKDIR}/${MY_P}
24
25 src_install() {
26         emake DESTDIR="${D}" install || die "Install failed"
27         dobin frontends/snipe || die
28         dodoc AUTHORS ChangeLog NEWS README TODO sample_auction.txt sample_config.txt || die
29 }
30
31 pkg_postinst() {
32         elog
33         elog "Please find a sample config at /usr/share/doc/${P}/sample_config.txt.bz2"
34         elog
35 }