]> Pileus Git - ~andy/sunrise/blob - net-misc/cloudvpn/cloudvpn-1.0.9.ebuild
net-misc/danbooru-grabber: Tested on x86, thanks to miniBill. Also removed distfile...
[~andy/sunrise] / net-misc / cloudvpn / cloudvpn-1.0.9.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 DESCRIPTION="secure mesh networking VPN"
6 HOMEPAGE="http://exa.czweb.org/"
7 SRC_URI="http://exa.czweb.org/releases/${P}.tar.bz2"
8
9 LICENSE="GPL-3"
10 SLOT="0"
11 KEYWORDS="~amd64 ~x86"
12 IUSE=""
13
14 RDEPEND="dev-libs/openssl"
15 DEPEND="dev-util/scons
16         ${RDEPEND}"
17
18 src_compile () {
19         # dont pass make's -l option, as scons uses it differently.
20         scons ${MAKEOPTS/-l[0-9]} || die "compilation failed"
21 }
22
23 src_install () {
24         dobin cloudvpn extras/initscripts/cloudctl || die
25         doman extras/man/cloudvpn.1 || die
26 }