]> Pileus Git - ~andy/sunrise/blob - net-misc/babeld/babeld-0.98.ebuild
net-misc/geomyidae: removed from sunrise, cause it is in main tree now
[~andy/sunrise] / net-misc / babeld / babeld-0.98.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 inherit toolchain-funcs
8
9 DESCRIPTION="a loop-free distance-vector routing protocol"
10 HOMEPAGE="http://www.pps.jussieu.fr/~jch/software/babel/"
11 SRC_URI="http://www.pps.jussieu.fr/~jch/software/files/${P}.tar.gz"
12
13 LICENSE="MIT"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 src_prepare() {
19         sed -e 's:/man/:/share/man/:' \
20                 -e '/^PREFIX/{s:=.*:= /usr:;}' -i Makefile || die
21 }
22
23 src_compile() {
24         emake \
25                 CC=$(tc-getCC) \
26                 "CDEBUGFLAGS=${CFLAGS}" \
27                 all || die "build failed"
28 }
29
30 src_install(){
31         emake "TARGET=${D}" install || die "install failed"
32         dodoc CHANGES README || die
33 }