]> Pileus Git - ~andy/sunrise/blob - net-mail/qmqtool/qmqtool-1.14.ebuild
app-dicts/words-bin: Adding ~amd64 keyword
[~andy/sunrise] / net-mail / qmqtool / qmqtool-1.14.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6
7 DESCRIPTION="A qmail queue manipulation program"
8 HOMEPAGE="http://jeremy.kister.net/code/qmqtool/"
9 SRC_URI="http://jeremy.kister.net/code/qmqtool/files/${P}.tgz"
10
11 LICENSE="Artistic"
12 SLOT="0"
13 KEYWORDS="~x86"
14 IUSE=""
15
16 RDEPEND="virtual/qmail
17         dev-lang/perl"
18
19 src_prepare() {
20         # make the configure script less capricious and ${ROOT}-friendly
21         # i.e. replace real directory/file checks with non-empty var checks
22         # and disallow calling perl
23         sed -i \
24                 -e 's:\[ -[dx]:[ -n:g' \
25                 -e 's:\[ ! -[dx]:[ ! -n:g' \
26                 -e '/^$perl/d' \
27                 configure || die
28 }
29
30 src_configure() {
31         # econf-incompatible
32         ./configure \
33                 --prefix="${D}"/usr \
34                 --scriptdir="${D}"/usr/bin \
35                 --perl=/usr/bin/perl \
36                 --qmaildir=/var/qmail \
37                 || die
38 }
39
40 src_install() {
41         emake install || die
42         dodoc README FAQ ChangeLog || die "dodoc failed"
43
44         docinto contrib/argus
45         dodoc contrib/argus/* || die "dodoc failed"
46
47         docinto contrib/cricket
48         dodoc contrib/cricket/* || die "dodoc failed"
49 }