]> Pileus Git - ~andy/sunrise/blob - net-libs/nativebiginteger/nativebiginteger-0.6.1.31.ebuild
net-p2p/NativeThread: Add RDEPEND
[~andy/sunrise] / net-libs / nativebiginteger / nativebiginteger-0.6.1.31.ebuild
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils flag-o-matic multilib toolchain-funcs
6
7 DESCRIPTION="NativeBigInteger libs for Freenet taken from i2p"
8 HOMEPAGE="http://www.i2p.net"
9 SRC_URI="http://dev.gentooexperimental.org/~tommy/${P}.tar.bz2"
10
11 LICENSE="|| ( public-domain BSD MIT )"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15
16 DEPEND="dev-libs/gmp
17         virtual/jdk"
18 RDEPEND="dev-libs/gmp"
19
20 QA_TEXTRELS="opt/freenet/lib/libjcpuid-x86-linux.so"
21
22 src_compile() {
23         append-flags -fPIC
24         tc-export CC
25         cp "${FILESDIR}"/Makefile .
26         make libjbigi || die
27         use amd64 || filter-flags -fPIC
28         make libjcpuid || die
29 }
30
31 src_install() {
32         make DESTDIR="${D}" LIBDIR=$(get_libdir) install || die
33 }