]> Pileus Git - ~andy/sunrise/blob - net-libs/libvuurmuur/libvuurmuur-0.8_beta2.ebuild
dev-db/dabo: Adding ~amd64 keyword, fixing deps, fixing distutils usage
[~andy/sunrise] / net-libs / libvuurmuur / libvuurmuur-0.8_beta2.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 inherit autotools eutils multilib
8
9 MY_PV=${PV/_beta/beta}
10 MY_P="Vuurmuur-${MY_PV}"
11
12 DESCRIPTION="Libraries and plugins required by Vuurmuur"
13 HOMEPAGE="http://www.vuurmuur.org"
14 SRC_URI="ftp://ftp.vuurmuur.org/releases/${MY_PV}/${MY_P}.tar.gz"
15
16 LICENSE="GPL-2"
17 SLOT="0"
18 KEYWORDS="~amd64 ~x86"
19 IUSE=""
20
21 DEPEND="net-firewall/iptables"
22 RDEPEND="${DEPEND}"
23
24 S="${WORKDIR}/${MY_P}/${PN}-${MY_PV}"
25
26 src_unpack() {
27         default
28         cd "${MY_P}"
29         unpack "./libvuurmuur-${MY_PV}.tar.gz"
30 }
31
32 src_prepare() {
33         epatch "${FILESDIR}"/libvuurmuur-plugin-0.7.patch   # no longer needed for >0.8_beta2
34         eautoreconf
35 }
36
37 src_configure() {
38         econf --with-plugindir=/usr/$(get_libdir)
39 }
40
41 src_install() {
42         emake DESTDIR="${D}" install || die "installing libvuurmuur failed"
43
44         # files needed but not yet installed by make
45         dodir /etc/vuurmuur/textdir || die "installing textdir failed"
46         insinto /etc/vuurmuur/plugins
47         doins plugins/textdir/textdir.conf || die "installing textdir.conf failed"
48 }