]> Pileus Git - ~andy/sunrise/blob - net-libs/http-parser/http-parser-1.0_pre20120413.ebuild
media-video/ucview: fix metadata.xml
[~andy/sunrise] / net-libs / http-parser / http-parser-1.0_pre20120413.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 inherit eutils multilib toolchain-funcs
8
9 DESCRIPTION="A parser for HTTP messages written in C. It parses both requests and responses"
10 HOMEPAGE="https://github.com/joyent/http-parser"
11 SRC_URI="mirror://github/hasufell/tinkerbox/${P}.tar.gz"
12
13 LICENSE="MIT"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 src_prepare() {
19         epatch "${FILESDIR}"/20120413-makefile.patch
20 }
21
22 src_compile() {
23         tc-export CC
24         emake library
25 }
26
27 src_install() {
28         insinto /usr/include/${PN}
29         doins http_parser.h
30         dolib.so libhttp_parser.so
31         newdoc README.md README
32 }