]> Pileus Git - ~andy/sunrise/blob - net-libs/NativeThread/NativeThread-20080330.ebuild
8227525897a4f1f4cc6e94dcb69be762a9a7024e
[~andy/sunrise] / net-libs / NativeThread / NativeThread-20080330.ebuild
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils flag-o-matic toolchain-funcs
6
7 DESCRIPTION="NativeThread for priorities on linux for freenet"
8 HOMEPAGE="http://www.freenetproject.org/"
9 SRC_URI="http://dev.gentooexperimental.org/~tommy/${P}.tar.bz2"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15
16 DEPEND="net-p2p/freenet
17         virtual/jdk"
18 RDEPEND=""
19
20 src_unpack() {
21         unpack ${A}
22         epatch "${FILESDIR}"/Makefile.patch
23 }
24
25 src_compile() {
26         append-ldflags -fPIC
27         tc-export CC
28         emake || die
29 }
30
31 src_install() {
32         into /opt/freenet
33         dolib.so libNativeThread.so
34 }